MapInfo Pro

Expand all | Collapse all

Frame with Image

  • 1.  Frame with Image

    Posted 27 days ago
    Hi,

    My client has a workspace with an image embeded in a .TAB and has done a Layout  integrating a Frame with the Map. In V16 the layout display properly, but when opening the same workspace in V17, the frame in the layout disapear so the image won't display in neither the layout nor the map.

    I tired to replicate the error on my workstation, but without success. The Workspace open properly in my V17 and the frame appear in the layout See ScreenShot
    taken from my Workstation
    Taken from my client's workstation
    Any suggestions how to resolve this?


    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------


  • 2.  RE: Frame with Image

    Posted 27 days ago
    Hi Guillaume
    You no longer require an image to have an associated tab file.
    Just "Insert - Image" directly onto the Layout.
    Regards​

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 3.  RE: Frame with Image

    Posted 27 days ago
    I understand that, but the clients need to open his old workspace and don't want to rebuild all their layout, any advice on how to keep their old workspace without having to redo the layout?

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 4.  RE: Frame with Image

    Pitney Bowes
    Posted 27 days ago
    Hi Guillaume,

    Would it be possible for you to attach the data set so that we can investigate? Having the data will make it much easier for us to track down the problem.

    You can use the Workspace Packager tool to bundle up all of the relevant files. You could either attach it here or send it to me.

    Thanks,
    Alicia


    ------------------------------
    Alicia Levesque
    Pitney Bowes Software
    ------------------------------



  • 5.  RE: Frame with Image

    Posted 27 days ago
      |   view attached
    Here's the workspace:


    Please note (if it helps) that the end-user was in Windows 7 and migrate to Windows 10. She observe the issue while migrating from Windows 7 to Windows 10 with her V17 version. When opening the workspace, the Frame are disapearing causing the image to disapear in the Layout which I am not able to replicate on my end.

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------

    Attachment(s)



  • 6.  RE: Frame with Image

    Pitney Bowes
    Posted 27 days ago
    Thanks!

    I will take a look and let you know what I find out.

    In the meantime, can you tell me if either you or the end-user is using MapInfo Pro Advanced (Raster)? Is it possible that one of you is using Advanced and the other is not?

    ------------------------------
    Alicia Levesque
    Pitney Bowes Software
    ------------------------------



  • 7.  RE: Frame with Image

    Pitney Bowes
    Posted 27 days ago
    Hi Guillaume,

    This appears to be a redraw issue. I can duplicate the problem, even using MapInfo Pro 16.0.3.

    I am running Windows 10 1709. What OS are you using? You can try running "winver". Did you state this runs correctly on Windows 7?

    The frame and image is still there. What I noticed is that I can double click in each frame that looks empty. This activates the embedded map in the layout frame. At this time, it will redraw and you will see the image in the map frame.

    I do NOT think this is related to using or not using MapInfo Pro Advanced (Raster).

    I will file this as a bug. If I find a workaround I will let you know.




    ------------------------------
    Alicia Levesque
    Pitney Bowes Software
    ------------------------------



  • 8.  RE: Frame with Image

    Posted 27 days ago
    I am running Windows 10 1809.

    Correct, this runs correctly on Windows 7 and she experienced the issue with Windows 10 MiPro V17.

    Thnaks for looking/investigating the issue


    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 9.  RE: Frame with Image

    Pitney Bowes
    Posted 27 days ago
    I found a workaround.

    If the frames are initially within view when the WOR is opened, they seem to draw fine. So I changed the layout view to "fit" the entire layout in view and saved to a WOR. Now when I open that WOR, all of the frames show the content.

    Is it possible to save the WORs so that all of the frames are in view? You can use the "Fit Layout in Window" button in the lower right corner of the layout window:
    Fit Layout

    Unfortunately changing the view after opening the WOR will not force the redraw.

    ------------------------------
    Alicia Levesque
    Pitney Bowes Software
    ------------------------------



  • 10.  RE: Frame with Image

    Posted 27 days ago
    I have transmitted the workaround to the end-user. I will keep you updated if the fix works well on her end.


    Really appreciate your assistance

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 11.  RE: Frame with Image

    Posted 21 days ago
    I was on-site with the end-user yesterday I  test the fixed and it's not working on their end. The issue is that when opening the workspace, the layout doesn't include the frame that embed the Tab with the images. This workspace use to work on V16 and I can't replicate the issue on my workstation as the frame display properly with the image on my laptop.

    The only difference I see is the Windows Version of the end-user, which is 1703. Mine is 1809.

    They are running MiPro 17.0.4.
    See the screenshot below detailing the issue:
    End-User

    My Laptop
    Please note that the end-user is also able to replicate the issue on another workstation within their environment with another user

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 12.  RE: Frame with Image

    Pitney Bowes
    Posted 21 days ago
    Hi Guillaume,

    I would like to clarify a few things.

    What fix did you test?

    When you opened the WOR, were all of the map frames initially within view? Or did you need to zoom out to bring the map frames into view?

    When you state that this workspace used to work with version 16, was it opened on the same exact system that has the problem? Or was V16 run on one system and V17 run on another similar system?


    ------------------------------
    Alicia Levesque
    Pitney Bowes Software
    ------------------------------



  • 13.  RE: Frame with Image

    Posted 21 days ago
    On the end-user workstation, there's no frame at all with the Image.In V16, it was the exact same workstation/config, Window Version, so winver 1703.

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 14.  RE: Frame with Image

    Posted 7 days ago
    Any other recommendations on why the frame disapear in V17? They used to display in V16 on the same workstation and I can't replicate the issue on my end

    ------------------------------
    Guillaume Fouquet, ing., P. Eng.
    Geospatial Expert / Expert Géospatial
    korem.com | Phone: (418) 647-1555 ext. 2167 | Toll free: 1-888-440-1MAP
    ------------------------------



  • 15.  RE: Frame with Image

    Posted 27 days ago
    Hi Guillame
    Well I can see a number of the frames do have photo images but some do not (the smaller ones).
    There are 59 png files that you supplied and 59 images shown.
    My results
    I don't know what that proves though?
    All I can suggest is that version 17 is patched to v17.0.4 to begin with.


    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------