MapInfo Pro

Expand all | Collapse all

Disaggregate not working in Mapinfo Pro V17.0.3 Discover

Jump to Best Answer
  • 1.  Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 10-29-2019 22:47
    Dear Support Team,

    We have a layer were we need to aggregate some objects. We tested the same layer in MapInfo Pro 17.0.2 and in MapInfo Pro V17.0.3 Discover.
    In MapInfo Pro 17.0.2 we can disaggregate the selected object but in MapInfo Pro V17.0.3 Discover if we select the same object the "Disaggregate" tool is greyed out?

    Any help will be greatly appreciated!

    Regards
    Minette


    ------------------------------
    Minette Lubbe
    Fraser Coast Regional Council
    Hervey Bay
    ------------------------------


  • 2.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Pitney Bowes
    Posted 10-30-2019 00:15
    Hi @Minette Lubbe  a common issue that can cause the behaviour you describe is the object selected cannot be split (i.e. already exists as individual components) or layer is not set as editable. There's a full explanation of the Disaggregate function in this article + a YouTube video that steps through the process.

    We encourage all members of the Knowledge Community to share their thoughts & wisdom and assist with questions & discussions posted on this website. If you'd like the Pitney Bowes Software Support team to work on a specific matter then best to open a Support Case, contact details for our team are available via this link.

    Thanks, Ashley

    ------------------------------
    Ashley Crane
    Regional Director, Software Support
    Pitney Bowes
    ------------------------------



  • 3.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 10-30-2019 00:22
    Edited by Minette Lubbe 10-30-2019 00:25
    Dear Ashley,

    As I have mentioned the object can be split. We tested the SAME data in both MapInfo 17.0.2 and MapInfo Discover 17.0.3. The layer was set to be editable in both. Disaggregate work in MapInfo 17.0.2 but was greyed out in MapInfo Discover 17.0.3 using the SAME data and process. We have used this function multiple times it works in the one version but not the other.....

    I think it is a problem in MapInfo Discover.....




    ------------------------------
    Minette Lubbe
    Fraser Coast Regional Council
    Hervey Bay
    ------------------------------



  • 4.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover
    Best Answer

    Pitney Bowes
    Posted 10-30-2019 01:05
    Hi @Minette Lubbe thanks for your update. One further thing to check, the "Disaggregate" button may appear to be greyed out (disabled) however the Disaggregate function (which is invoked from the drop-down) is still available by clicking on the button, here's a quick screenshot:

    in the above example, the "Disaggregate to Lines" is disabled which makes the button appear greyed out. However when clicked the greyed out button drop-down appears & "Disaggregate" can then be selected. Does this describe the situation you are seeing?

    Thanks, Ashley


    ------------------------------
    Ashley Crane
    Regional Director, Software Support
    Pitney Bowes
    ------------------------------



  • 5.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 10-30-2019 01:08
    Exactly - Thank you Ashley problem solved!

    ------------------------------
    Minette Lubbe
    Fraser Coast Regional Council
    Hervey Bay
    ------------------------------



  • 6.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Community Manager
    Posted 10-30-2019 08:55
    Hi Minette,

    It sounds like your question has been resolved - I'm glad you were able to get everything working! At this point, I'd like to ask you to go back into this thread and choose which post is the Best Answer for your question. You can do this by clicking on the down-arrow next to "reply" and then click "best answer" on the post that you want to mark. This will help future community members who may have a similar question down the road. You can read more about best answers in this FAQ post.

    Thank you!

    ------------------------------
    Sydney Lawton
    Community Manager
    ------------------------------



  • 7.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 4 days ago
    G'day Ashley, does it go without saying that this misleading behaviour will be fixed in the next update?

    Regards, Mark

    ------------------------------
    Mark Duffett
    Mineral Resources Tasmania
    Department of State Growth
    Rosny Park
    ------------------------------



  • 8.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Pitney Bowes
    Posted 2 days ago
    @Mark Duffett  ​sorry to hear that this behaviour is frustrating you.

    It can be hard to get the right balance between making the User Interface productive to enable easy access to all capabilities & visually clear as to the state/availability of the various functions. If you'd like to see this changed in the future it would be great to have this logged as a suggestion in the Software Ideas site. You can easily access this from within Knowledge Communities under the "Pitney Bowes Sites" menu at the top of this page. Share the Idea number/URL here and others from the Community can vote to increase the visibility of this suggestion.

    Thanks, Ashley

    ------------------------------
    Ashley Crane
    Regional Director, Software Support
    Pitney Bowes
    ------------------------------



  • 9.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 2 days ago
    Done:  I must say though, it seems a no-brainer to me - I'm at a loss to come up with any reason why the current behaviour could be considered desirable.  Happy to be enlightened.

    cheers, Mark

    ------------------------------
    Mark Duffett
    Mineral Resources Tasmania
    Department of State Growth
    Rosny Park
    ------------------------------



  • 10.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Pitney Bowes
    Posted 2 days ago
    Thanks @Mark Duffett ​- I agree it would be good to review +1 vote from me. Who else can get behind this idea? Cheers, Ashley

    ------------------------------
    Ashley Crane
    Regional Director, Software Support
    Pitney Bowes
    ------------------------------



  • 11.  RE: Disaggregate not working in Mapinfo Pro V17.0.3 Discover

    Posted 2 days ago

    +1 vote from me too!
    I spent way to much time to solve how to disaggregate collection objects in tables where there shouldn't be any collections until I by mistake discovered active tools under a greyed out drop down.

    Doesn't boost your confidence to end up recreating objects to solve the problem when I could have solved all of them in an hour had I looked under a greyed out button :)



    ------------------------------
    Christina Lundgren
    Svenska Kyrkan i Uppsala, Uppsala Pastorat
    Uppsala
    ------------------------------