MapInfo Pro

Expand all | Collapse all

Problem with Table--> Append Rows

  • 1.  Problem with Table--> Append Rows

    Posted 03-26-2020 08:43
      |   view attached
    Hi

    Anyone knows the reason why appending rows to table fails? I open tables "260320_MSR_Vork_kohalik" (table where I want to append) and "260320_kust_lisam_test_BU" (table what I want to append). Then Table--> Append Rows-->
    Append Table: 260320_kust_lisam_test_BU
    to Table: 260320_MSR_Vork_kohalik

    --> OK. Now MapInfo closes itself and when I open MapInfo again and open same tables, then rows have not been appended. I think that problem is caused by table I want to append ("260320_kust_lisam_test_BU") because when I delete majority of columns from that table, then append works. Tables are included in attachment. I am using MapInfo Pro Version 2019 (64 bit), Release Build 58.

    Thanks

    Asko Põder


    ------------------------------
    Asko Põder
    Knowledge Community Shared Account
    ------------------------------

    Attachment(s)

    zip
    Append.zip   25K 1 version


  • 2.  RE: Problem with Table--> Append Rows

    Posted 03-26-2020 20:18
    ​Hi Asko,

    You have just discovered that although MapInfo will work with table names that start with a number it does not like them which is why it adds an underscore at the start of the name.
    If you add an alpha character in front of the table name (eg. A260320_MSR_Vork_kohalik) the append will save correctly.

    Cheers,

    ------------------------------
    David Murphy
    GIS Officer
    Swan Hill Rural City Council
    Swan Hill VIC
    ------------------------------



  • 3.  RE: Problem with Table--> Append Rows

    Posted 03-27-2020 03:26
    Hi

    Thank you for your answer. I renamed my tables, but still same problem.

    Cheers


    Asko Põder

    Estonian Agricultural Board

    ------------------------------
    Asko Põder
    Knowledge Community Shared Account
    ------------------------------



  • 4.  RE: Problem with Table--> Append Rows

    Posted 03-27-2020 03:43
    Hi Asko

    You might have stumbled upon a limitation around the number of columns that can be listed using the Insert statement. We'll need to investigate this a bit further.

    I was able to reproduce the crash when I used the Append Rows feature in MapInfo Pro.
    I did, however, find a workaround using the MapBasic window, or even the new SQL Window.

    You can use this statement to insert all the records from _260320_MSR_Vork_kohalik into _260320_kust_lisam_test_BU

    Insert Into _260320_kust_lisam_test_BU Select * From _260320_MSR_Vork_kohalik

    I'll pass this onto our support team to investigate further.

    ------------------------------
    Peter Horsbøll Møller
    Distinguished Engineer
    Pitney Bowes Software & Data
    ------------------------------



  • 5.  RE: Problem with Table--> Append Rows

    Posted 03-27-2020 04:14
    Hi

    Thank you for investigating this. This problem is in MapInfo version 2019. In MapInfo ver. 17 there is no problem.

    Best

    Asko Põder
    Estonian Agricultural Board

    ------------------------------
    Asko Põder
    Knowledge Community Shared Account
    ------------------------------



  • 6.  RE: Problem with Table--> Append Rows

    Posted 03-27-2020 05:25
    I remove boundary definitions and add row is working perfectly in both v17 and v19.

    ------------------------------
    Mati Tee
    Ruumab OÛ
    Tartu
    ------------------------------



  • 7.  RE: Problem with Table--> Append Rows

    Posted 03-27-2020 05:49
    Edited by Peter Horsbøll Møller 03-27-2020 05:51
    Thanks, Mati.

    That might be helpful for our support.
    But MapInfo Pro shouldn't crash.

    Let's see what support come up with

    PS: Maybe my solution lets you add the records but if the bounds are smaller on the table you insert the records into, you can not really see them. They will be "smashed" against the bounds.

    ------------------------------
    Peter Horsbøll Møller
    Distinguished Engineer
    Pitney Bowes Software & Data
    ------------------------------



  • 8.  RE: Problem with Table--> Append Rows

    Employee
    Posted 03-30-2020 12:47
    Edited by Bob Fortin 03-30-2020 14:31
    We have identified this as a bug. It was introduced in v2019.

    It has to do with the length of the insert statement we are creating in the dialog.
    It is only in the dialog, so it can be done via mapbasic app, mapbasic window or sql window.

    Peter's workaround also works.

    We will fix it in an upcoming version.

    ------------------------------
    Bob Fortin
    Software Architect and Distinguished Engineer
    MapInfo Pro Development Team
    ------------------------------



  • 9.  RE: Problem with Table--> Append Rows

    Employee
    Posted 03-31-2020 10:22
    Good news. We were able to squeak this fix into the 2019.1 which should be available shortly.

    ------------------------------
    Bob Fortin
    Software Architect and Distinguished Engineer
    MapInfo Pro Development Team
    ------------------------------