MapInfo Pro

Expand all | Collapse all

MapInfo Pro 15.0.3 (32-bit) very slow to start

  • 1.  MapInfo Pro 15.0.3 (32-bit) very slow to start

    Posted 12-18-2018 23:07
    Hello all,

    I am running MapInfo Pro 15.0.3 (32-bit) on WIndows 7 (64-bit) and it is very slow to start.

    The cursor sits there spinning for several minutes before MapInfo finally finishes starting. MapInfo then behaves normally.

    I have tried stuff like unticking all the auto-loading tools and minimising the Startup Preferences (only preference ticked is "Save Queries in Workspaces". I also removed the startup.wor.

    I have set MapInfo to open with no previous session, no Quick start Dialog.

    MapInfo does eventually behave itself, but it is frustrating first thing.

    ------------------------------
    Nick Lawrence
    Mr
    TMR-Policy and Planning
    Brisbane
    ------------------------------


  • 2.  RE: MapInfo Pro 15.0.3 (32-bit) very slow to start

    Posted 12-19-2018 05:43
    Hi Nick

    One typical cause of this is the printer settings.
    That can be the printer preference of MapInfo or the printers referenced in the workspace you are opening.

    Try to switch the MapInfo preferred printer to the Windows default printer.
    Try to disable loading printer preferences from workspaces.

    Let us know how this goes

    ------------------------------
    Peter Horsbøll Møller
    Pitney Bowes
    ------------------------------



  • 3.  RE: MapInfo Pro 15.0.3 (32-bit) very slow to start

    Posted 12-19-2018 20:41
    I am opening MapInfo from the Start menu (not double-clicking a workspace)

    The default printer is Adobe PDF which is the default printer in windows. I tried switching to PDF995, but that did not solve it.

    I always have disabled the saving/loading printer preferences from workspaces. In my organisation, we share workspaces between different people with different printers, so we all disable printer preferences to keep the workspaces generic.

    ------------------------------
    Nick Lawrence
    Mr
    TMR-Policy and Planning
    Brisbane
    ------------------------------



  • 4.  RE: MapInfo Pro 15.0.3 (32-bit) very slow to start

    Pitney Bowes
    Posted 12-19-2018 22:54
    ​Nick,

    Do you have any network locations used for common files (like PRJ file)? Maybe this is a network issue? Do you use workgroup installer?

    One way to check it could be to temporary rename your preference file ("C:\Users\<Username>\AppData\Roaming\MapInfo\MapInfo\MAPINFOW.PRF") and see if MapInfo Pro loads faster.

    Regards,
    Andrei


    ------------------------------
    Andrei Veselov
    Knowledge Community Shared Account
    Troy NY
    ------------------------------



  • 5.  RE: MapInfo Pro 15.0.3 (32-bit) very slow to start

    Pitney Bowes
    Posted 12-20-2018 05:12
    Note that in order to see the folder of preference file that Andrei references, you will need to set Windows Explorer to display hidden files and folders if you have not already done so.
    If you don't see the menus in Explorer, press Alt. Then find the Options dialog under one of the menus, go to the Display tab, and select the radio button to display hidden files and folders.

    ------------------------------
    Hakan Karlsson
    Presales, Pitney Bowes Sweden
    hakan.karlsson@pb.com
    ------------------------------



  • 6.  RE: MapInfo Pro 15.0.3 (32-bit) very slow to start

    Posted 01-07-2019 18:45
    I have solved it by getting my work computer replaced.
    Other software on my previous computer was also having problems, and IT decided to just replace the computer.
    Looks like it was all just a result of slowly dying hardware.

    ------------------------------
    Nick Lawrence
    Mr
    TMR-Policy and Planning
    Brisbane
    ------------------------------