Spectrum Spatial (SSA/LIM)

  • 1.  Change in Java support

    Pitney Bowes
    Posted 02-12-2019 07:12
    Edited by Richard Peebles 02-12-2019 14:17

    Recently, Pitney Bowes announced that due to the changes in Java versioning and licensing we will no longer be redistributing and installing Java with our Spectrum and Spectrum Spatial Analyst products. So what does this mean to you?

    First, your current Spectrum or SSA product installations are perfectly fine and can run with their installed versions of Java for as long as needed. This change only impacts our ability to redistribute Java with upcoming releases.

    Second, since we will no longer be including a Java JDK with Spectrum or SSA, clients will be required to install an appropriate alternative starting with the next product release, scheduled to occur in October. The JDK that we had previously installed will not be used. That JDK will be uninstalled as part of the upgrade process.

    Despite these changes, the good news is that we will support any Java JDK as long as it is a version 8 JDK. As of now we have tested Oracle and Zulu (from Azul Systems) and we also intend on testing either OpenJDK or Corretto. If you are not familiar with Corretto, it is a free, multi-platform distribution of OpenJDK provided and used by Amazon AWS.

    Finally, we will be documenting the specific distributions and versions of Java that we test with during our product development. 



    ------------------------------
    Cary Peebles
    Senior Fellow and Chief Architect, LI & CIM
    ------------------------------